[résolu] Pb double boot W10 / LM sur sdb

Toutes les demandes concernant l'installation de LinuxMint
Avatar du membre
Minuxien
Messages : 25
Enregistré le : ven. 18 mai 2018 10:56

[résolu] Pb double boot W10 / LM sur sdb

Messagepar Minuxien » ven. 18 mai 2018 11:50

Bonjour,

Encore un sujet de problème d'installation W10/LM ... j'espère que je ne suis pas passé à coté d'une solution déjà proposée , dans le cas contraire, désolé du dérangement.
Donc ... je pars du principe que je réinstalle tout pour partir proprement, avec 2 sources ,W7 et LM, sur clef usb bootable.
Configuration :
Mon pc était livré avec un disque dur classique ( sda ) qui comprenait une partition bootable freedos et j'ai ajouté un SSD pour la performance système bien sur ( sdb ).

Premier test
Je supprime windows et installe linux sur mon SSD, tout va bien. Mais je me rend compte que certains logiciel ne sont disponible que sur Windows. Je décide d'installer mon Windows en dual boot.
Bien sur j'installe windows, il ne détecte plus mon linux. J'utilise easyBCD pour modifier le boot de windows qu'il me propose linux . Ca marche. C'est pas propre mais ça marche. Mais c'est pas propre.

Second test
J'installe windows 7 , j'installe linux cela fonctionne mais impossible de mettre a jour mon windows a priori car il ne peut pas modifier le boot. Je présume que c'est à cause du linux, je décide de reprendre.

Troisième , quatrième, cinquième etc test(s)
J'ai un peu perdu le fil des tests successifs...
Lors de l'installation de Mint, la proposition par défaut est installé a coté de Freedos. Cela ne me convient pas car il s'agit de mon disque standard.
Je choisi donc une installation "manuel" pour faire 3 partitions , / et swap sur mon ssd puis le /home sur mon disque standard.

Et la ... la ça ne va plus.

Je ne sais pas si je dois choisir partition logique ou primaire pour la racine, en début ou fin de disque (pour moi ca n'avait pas d'importance). J'ai l'impression d'avoir essayé les deux (et bien plus encore ) et que cela ne fonctionne pas.

Soit je boot sur linux, soit windows, soit je n'ai carrement plus de boot (message d'erreur indiquant qu'il y a un problème avec le grub). J'ai passé mon après midi a faire des tests sans trouver la bonne façon de faire. Aussi j'ai fini par venir tenter ma chance en demandant votre aide :)
Modifié en dernier par Minuxien le sam. 19 mai 2018 10:46, modifié 1 fois.
CPU : Intel(R)_Core(TM)_i7-4810MQ_CPU_@_2.80GHz - RAM : 8Go - SSD : 256Go - HDD : 1To - GPU GTX 870M

capdeframint
Messages : 497
Enregistré le : jeu. 2 juin 2016 08:57

Re: Pb double boot W10 / LM sur sdb

Messagepar capdeframint » ven. 18 mai 2018 13:31

J'ai du mal à suivre tes difficultés car ce que tu veux faire est pourtant très facile à réaliser puisque tu veux repartir de zéro.
J'ai fait exactement pareil sur deux ordinateurs, une tour et un portable, tous les deux équipés d'un nouveau disque SSD de 250 Go en plus du disque dur d'origine.
Par contre le SSD est le disque de boot et le HDD uniquement utilisé pour la partition /home de Linux.j'ai fait ce choix car je n'utilise plus Windows pour créer de gros documents mais sinon j'aurais aussi stocké les documents réalisés sous Windows dans une deuxième partition sur le HDD.
Bien évidemment j'ai d'abord installé Windows en totalité sur le SSD ( partition de 210 Go) puis Linux (partition racine de 30 Go) et le /home sur le HDD.
Avec cette installation sur les deux ordinateurs, je n'ai rencontré aucun problème de fonctionnement, de boot ou de mise à jour des deux systèmes d'exploitation.
J'ai par exemple réalisé hier la mise à jour 1803 du mois de mai pour Windows 10 sans le moindre problème.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LM18 Cinnamon
Double boot: Windows 10 Family (en totalité sur le SSD) + LM18 Cinnamon (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia. LMDE2 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LMDE2 (/ sur le SSD et Home sur le HDD).

mézig
Messages : 720
Enregistré le : mar. 14 nov. 2017 14:40

Re: Pb double boot W10 / LM sur sdb

Messagepar mézig » ven. 18 mai 2018 13:34

Moi non plus, je ne vois pas le probleme,si tu installes d'abord Windows et ensuite Linux ça doit fonctionner sans probleme
Intel Pentium Dual CPU E2140 -- Nvidia GF108 -- 4 Go de RAM -- Ubuntu 17.10 Mate -- Deepin 15.5 -- Ubuntu Unity 18.04
Intel Pentium CPU 4405U @ 2.10GHz × 4 -- Intel HD Graphics 510 (Skylake GT1) -- 4 Go de RAM -- Deepin 15.5 -- Ubuntu 18.04

Avatar du membre
victoria
Messages : 584
Enregistré le : dim. 21 janv. 2018 20:10
Localisation : Dans mon esprit

Re: Pb double boot W10 / LM sur sdb

Messagepar victoria » ven. 18 mai 2018 13:56

Pour complèter les réponses mais surement des liens que tu as déjà vu et lu avant de poster j'imagine.

cet excellent site
http://ikewdu.free.fr/category/dual-boot/

et la doc de Ubuntu (parfait pour toi, un windows 7 et un linux)
https://doc.ubuntu-fr.org/tutoriel/comm ... ec_bootmgr

et aussi celui là (un peu plus généraliste diront nous)
https://doc.ubuntu-fr.org/cohabitation_ubuntu_windows
CPU : i7 3840qm @ 3.8Ghz - RAM : 4x8 Go - SSD : 256 Go - HDD : 1 000 Go + 2 000 Go - GPU : GTX 670m 4Go
Debian Stretch 9.4 Mate
Slovenija, moja država, moje poreklo, moja kri in moj ponos.
Triglav, naš naravni Eifflov stolp.

Avatar du membre
Minuxien
Messages : 25
Enregistré le : ven. 18 mai 2018 10:56

Re: Pb double boot W10 / LM sur sdb

Messagepar Minuxien » ven. 18 mai 2018 14:44

Je vous remercie de vos réponses.
Je vais aller lire les liens et vous dire ensuite.

Le point est , semble t il différent, que je souhaitais installé linux et windows sur le SSD et que l'installateur linux ne me le propose pas par défaut. Et quand j'essaye de le faire manuellement cela ne fonctionne pas, sans doute que je n'ai pas régler les types de partition comme il faut, je suppose du moins
CPU : Intel(R)_Core(TM)_i7-4810MQ_CPU_@_2.80GHz - RAM : 8Go - SSD : 256Go - HDD : 1To - GPU GTX 870M

Avatar du membre
arghlub
modérateur
Messages : 2905
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Pb double boot W10 / LM sur sdb

Messagepar arghlub » ven. 18 mai 2018 14:48

Salut,

Minuxien a écrit :Le point est , semble t il différent, que je souhaitais installé linux et windows sur le SSD et que l'installateur linux ne me le propose pas par défaut.

Essaie peut-être de débrancher ton HDD lors de l'installation (ton SSD sera forcément reconnu vu que cela sera le seul disque), et tu le rebranches par la suite. ;)
Portable • Lenovo G50-80 LinuxMint 18.3 XFCE 4.12.3
Tour (custom)CM MSI Z270 Gaming M3 | CPU Intel I7-7700K | CG MSI Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | Debian 9 XFCE 4.12.3 (+ de multiples machines virtuelles)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

Avatar du membre
Minuxien
Messages : 25
Enregistré le : ven. 18 mai 2018 10:56

Re: Pb double boot W10 / LM sur sdb

Messagepar Minuxien » ven. 18 mai 2018 14:52

C'est ce que je pensais faire hier soir, avant de me souvenir qu'il n'y avait pas de trappe de visite pour accéder aux disques, il faut que je démonte la carcasse du pc portable pour ça et j'avoue que cela ne me motive pas des masses ...

La dernière fois j'ai voulu testé l'installation par défaut "a coté de" et sur l'ecran suivant (capture trouvé sur internet )
Image
La tirette en haut ne me permet pas d'accéder à mon second disque (SSD)
CPU : Intel(R)_Core(TM)_i7-4810MQ_CPU_@_2.80GHz - RAM : 8Go - SSD : 256Go - HDD : 1To - GPU GTX 870M

Avatar du membre
arghlub
modérateur
Messages : 2905
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Pb double boot W10 / LM sur sdb

Messagepar arghlub » ven. 18 mai 2018 15:03

As-tu essayé de simplement modifier l'ordre de boot dans le bios ? Tu fais passer ton SSD avant le HDD.
Portable • Lenovo G50-80 LinuxMint 18.3 XFCE 4.12.3
Tour (custom)CM MSI Z270 Gaming M3 | CPU Intel I7-7700K | CG MSI Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | Debian 9 XFCE 4.12.3 (+ de multiples machines virtuelles)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

Avatar du membre
Minuxien
Messages : 25
Enregistré le : ven. 18 mai 2018 10:56

Re: Pb double boot W10 / LM sur sdb

Messagepar Minuxien » ven. 18 mai 2018 15:14

Oui et il n'a pas réussi a booté sur le linux (il me semble en tout cas, j'ai fais tellement d'essai je pourrais me tromper)
CPU : Intel(R)_Core(TM)_i7-4810MQ_CPU_@_2.80GHz - RAM : 8Go - SSD : 256Go - HDD : 1To - GPU GTX 870M

cyrille
Messages : 444
Enregistré le : mar. 19 sept. 2017 08:49

Re: Pb double boot W10 / LM sur sdb

Messagepar cyrille » ven. 18 mai 2018 15:31

Perso je configurerai le SSD pour qu'il boote en premier dessus

J'installerai dessus W7 puis LINUX (racine / et le swap)

Je mettrais le /home sur le HDD

Ensuite je redirigerais tous ce qui est les dossiers persos de W7 sur le HDD

J'optimiserais les 2 systèmes pour ne pas "trop fatiguer le SSD"


Mes 2 sous ;)

Bon courage
PC perso : DELL Latitude E5430, SSD, Linux Mint 18.2 Sonya, Cinnamon
Parc de Laptops DELL LATITUDE E6*** sous LINUX MINT 64bit, Linux Mint 18.2 Sonya, Cinnamon
---------------------------------------------------
Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STRETCH 9.4


Retourner vers « Installation »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité