[résolu] Comment réparer simple-scan ?

Installation, configuration des logiciels que vous souhaitez installer.
Avatar du membre
Scrat
Messages : 81
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

[résolu] Comment réparer simple-scan ?

Messagepar Scrat » sam. 13 oct. 2018 20:20

Bonjour.

Suite à cette discussion à propos de l'installation d'une imprimante-scanner Canon en WIFI, j'ouvre un nouveau sujet à propos de simple-scan qui est installé par défaut dans LM 19 Cinnamon.

Je résume le problème:
1) en août, après l'installation réussie du pilote Canon pour l'imprimante et l'échec de l'installation du pilote Canon ScangearMP pour le scanner, simple-scan reconnaissait le scanner et fonctionnait parfaitement.
2) deux mois et quelques mises à jour plus tard, simple-scan ne détectait plus le scanner, ce qui m'a amené à retenter l'installation du pilote Canon ScangearMP pour le scanner. Après installation d'une librairie manquante, l'installation du pilote Canon se déroule normalement et la commande scangearmp me permet de scanner. Mais simple-scan ne détecte toujours pas le scanner.

Il est donc vraisemblable que les paquets de simple-scan ont été endommagés au cours des deux mois écoulés entre l'installation de l'imprimante en août et aujourd'hui. Ma question est donc la suivante: comment réparer simple-scan ?

Je résume ce que j'ai tenté:
1) installation de xsane et des paquets libsane-extras et libsane-extra-commons: xsane ne détecte pas le scanner.
2) suite à une discussion vue sur le forum Ubuntu où le non fonctionnement de simple-scan résultait d'un problème de droits, essai de simple-scan en ligne de commande avec sudo: toujours pas de détection du scanner.
3) désinstallation et réinstallation de simple-scan avec redémarrage de la machine: toujours pas de détection du scanner.
4) essai de simple-scan avec l'option -d pour obtenir des informations de débogage:

Code : Tout sélectionner

richard@pc-linuxshop-5678:~$ simple-scan -d
[+0,00s] DEBUG: simple-scan.vala:637: Starting Simple Scan 3.28.0, PID=2212
[+0,02s] CRITICAL: g_action_print_detailed_name: assertion 'g_action_name_is_valid (action_name)' failed
[+0,02s] CRITICAL: gtk_application_set_accels_for_action: assertion 'detailed_action_name != NULL' failed
[+0,04s] DEBUG: app-window.vala:1714: Loading state from /home/richard/.cache/simple-scan/state
[+0,04s] DEBUG: app-window.vala:1671: Restoring window to 600x394 pixels
[+0,04s] DEBUG: autosave-manager.vala:64: Loading autosave information
[+0,04s] DEBUG: autosave-manager.vala:259: Waiting to autosave...
[+0,08s] DEBUG: scanner.vala:1454: sane_init () -> SANE_STATUS_GOOD
[+0,08s] DEBUG: scanner.vala:1460: SANE version 1.0.27
[+0,08s] DEBUG: scanner.vala:1521: Requesting redetection of scan devices
[+0,08s] DEBUG: scanner.vala:806: Processing request
[+0,14s] DEBUG: autosave-manager.vala:281: Autosaving book information
[+0,22s] DEBUG: app-window.vala:1775: Saving state to /home/richard/.cache/simple-scan/state
[+6,26s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+6,26s] DEBUG: scanner.vala:1521: Requesting redetection of scan devices
[+6,26s] DEBUG: scanner.vala:806: Processing request
[+6,36s] DEBUG: app-window.vala:1775: Saving state to /home/richard/.cache/simple-scan/state
[+12,56s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+12,66s] DEBUG: app-window.vala:1775: Saving state to /home/richard/.cache/simple-scan/state
[+27,12s] DEBUG: autosave-manager.vala:195: Deleting autosave records
[+27,12s] DEBUG: scanner.vala:1597: Stopping scan thread
[+27,12s] DEBUG: scanner.vala:806: Processing request
[+27,12s] DEBUG: scanner.vala:1608: sane_exit ()


On voit deux messages notés CRITICAL et "failed". Ça ne m'inspire pas. :mrgreen:

Je précise que ce problème de non détection du scanner avec simple-scan et xsane n'est pas critique dans la mesure où le scanner est bien détecté par la commande scangearmp du pilote Canon. Simplement, je déteste rester sur un échec, et j'aimerais bien comprendre ce qui a pu être cassé et comment alors que simple-scan fonctionnait très bien il y a deux mois. Alors toute proposition d'aide sera la bienvenue... ;)
Modifié en dernier par Scrat le sam. 20 oct. 2018 17:53, modifié 1 fois.
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19 Tara - Cinnamon 3.8.9
Noyau Linux 4.15.0-36-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

Avatar du membre
tyrry
Messages : 3885
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Comment réparer simple-scan ?

Messagepar tyrry » sam. 13 oct. 2018 21:29

Slt ,
te dirait bien de faire :

Code : Tout sélectionner

sudo rm -rf /home/richard/.cache/simple-scan

voir si il y a du mieux , mais sans convictions ;)
@+
Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: SolydX 9 (stretch)
Kernel: 4.9.0-6-amd64 x86_64
CPU: Intel Core i3-2130 RAM: -8 go Graphics Card: Intel 2nd Generation Core Processor
Dicton de tyrry : C'est pas parce qu'on sait pas se servir de xfce qu'il est nul........

Avatar du membre
Scrat
Messages : 81
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

Re: Comment réparer simple-scan ?

Messagepar Scrat » dim. 14 oct. 2018 18:47

Bonjour.

Bonne idée de tenter une suppression du cache... mais ça ne change rien ! :|
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19 Tara - Cinnamon 3.8.9
Noyau Linux 4.15.0-36-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

capdeframint
Messages : 682
Enregistré le : jeu. 2 juin 2016 08:57

Re: Comment réparer simple-scan ?

Messagepar capdeframint » dim. 14 oct. 2018 19:21

Effectivement, avec LM19 Cinnamon, chez moi aussi Simple Scan fonctionne avec ma Canon Pixma MG 5650 alors qu'il n'a jamais fonctionné avec LM18 (toutes versions) et LMDE2 ou 3.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE3 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE3 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM19 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM19 (/ sur le SSD et Home sur le HDD).

Avatar du membre
Scrat
Messages : 81
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

Re: Comment réparer simple-scan ?

Messagepar Scrat » dim. 14 oct. 2018 20:03

@capdeframint: Ça fonctionnait chez moi au début. Est-ce que tu pourrais mettre une copie d'écran montrant les paquets installés pour simple-scan et pour sane ? Ça me permettrait peut-être de voir si j'ai supprimé quelque chose. Et aussi quelle version du noyau utilises-tu ?

Sinon, j'ai continué à explorer internet avec les deux messages d'erreur de simple-scan -d: beaucoup de personnes semblent avoir eu le même problème de non détection du scanner, et la solution proposée est toujours d'installer les pilotes propriétaires et d'oublier simple-scan, ce qui ne m'aide pas à trouver l'origine de mon problème. :?
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19 Tara - Cinnamon 3.8.9
Noyau Linux 4.15.0-36-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

Avatar du membre
arghlub
modérateur
Messages : 4138
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Comment réparer simple-scan ?

Messagepar arghlub » dim. 14 oct. 2018 20:10

Salut Scrat,

Scrat a écrit :Est-ce que tu pourrais mettre une copie d'écran montrant les paquets installés pour simple-scan et pour sane ?

Pour connaitre les dépendances d'un paquet, utilise cette commande :

Code : Tout sélectionner

apt-cache depends NOM_PAQUET

Donc pour simple-scan et sane :

Code : Tout sélectionner

apt-cache depends simple-scan && apt-cache depends xsane

;)
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | MX Linux 17.1 | LinuxMint 19 Tara | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | tripleBoot : Debian 9 | MX Linux 17.1 | LinuxMint 19 | XFCE (bien sûr ...)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

Avatar du membre
Scrat
Messages : 81
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

Re: Comment réparer simple-scan ?

Messagepar Scrat » lun. 15 oct. 2018 15:39

Bonjour.

Résultat des commandes apt-cache:

Code : Tout sélectionner

richard@pc-linuxshop-5678:~$ apt-cache depends simple-scan
simple-scan
 |Dépend: <default-dbus-session-bus>
    dbus-user-session:i386
    dbus-user-session
  Dépend: <dbus-session-bus>
    dbus-user-session:i386
    dbus-user-session
    dbus-x11:i386
    dbus-x11
  Dépend: xdg-utils
 |Dépend: dconf-gsettings-backend
  Dépend: <gsettings-backend>
    dconf-gsettings-backend
  Dépend: libc6
  Dépend: libcairo2
  Dépend: libcolord2
  Dépend: libgdk-pixbuf2.0-0
  Dépend: libglib2.0-0
  Dépend: libgtk-3-0
  Dépend: libgusb2
  Dépend: libpackagekit-glib2-18
  Dépend: libsane1
  Dépend: libwebp6
  Dépend: libwebpmux3
  Dépend: zlib1g


Code : Tout sélectionner

richard@pc-linuxshop-5678:~$ apt-cache depends xsane
xsane
  Dépend: libc6
  Dépend: libgimp2.0
  Dépend: libglib2.0-0
  Dépend: libgtk2.0-0
  Dépend: libjpeg8
  Dépend: liblcms2-2
  Dépend: libpng16-16
  Dépend: libsane1
  Dépend: libtiff5
  Dépend: zlib1g
  Dépend: xsane-common
  Recommande: cups-client
    cups-client:i386
 |Recommande: firefox
  Recommande: <www-browser>
    dillo
    edbrowse
    hv3
    lynx:i386
    lynx
    chromium-browser
    elinks
    epiphany-browser
    falkon
    firefox
    konqueror
    links
    links:i386
    links2
    links2:i386
    netrik
    sugar-browse-activity
    surf
    w3m:i386
    w3m
    xemacs21-mule
    xemacs21-mule-canna-wnn
    xemacs21-nomule
  Suggère: gimp
 |Suggère: gocr
 |Suggère: cuneiform
    cuneiform:i386
 |Suggère: tesseract-ocr
  Suggère: ocrad
    ocrad:i386
  Suggère: gv
 |Suggère: hylafax-client
  Suggère: mgetty-fax


En vérifiant avec le gestionnaire de paquets, il semble que tous les paquets dont dépendent simple-scan et xsane soient bien installés. Je suis toujours dans le noir complet. :|

Quelqu'un pourrait-il me montrer le résultat de ces commandes sur un système où simple-scan fonctionne pour voir s'il ne me manquerait pas une dépendance ?
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19 Tara - Cinnamon 3.8.9
Noyau Linux 4.15.0-36-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

Avatar du membre
tyrry
Messages : 3885
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Comment réparer simple-scan ?

Messagepar tyrry » lun. 15 oct. 2018 16:06

Slt ,
essais de réinstaller cinnamon , une dép foireuse à pu se glissé quelque part :

Code : Tout sélectionner

sudo apt update && sudo apt install -f

Code : Tout sélectionner

sudo apt clean && sudo apt autoremove

Code : Tout sélectionner

sudo apt install --reinstall mint-meta-cinnamon

re test simple-scan ;)
@+
Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: SolydX 9 (stretch)
Kernel: 4.9.0-6-amd64 x86_64
CPU: Intel Core i3-2130 RAM: -8 go Graphics Card: Intel 2nd Generation Core Processor
Dicton de tyrry : C'est pas parce qu'on sait pas se servir de xfce qu'il est nul........

Avatar du membre
Scrat
Messages : 81
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

Re: Comment réparer simple-scan ?

Messagepar Scrat » lun. 15 oct. 2018 17:04

tyrry a écrit :essais de réinstaller cinnamon


Euuuh... :shock: Merci pour cette suggestion radicale, mais je ne maîtrise pas suffisamment Linux pour me lancer dans ce genre d'opération sans comprendre ce que fait chaque commande. :? J'ai parcouru la doc de apt, et entre les options update, upgrade, clean et autres, je suis un peu largué. :oops:

Mis à part simple-scan qui ne détecte plus le scanner, j'ai un système qui me donne entièrement satisfaction: je peux faire tourner mes divers logiciels sans problème et je peux imprimer et scanner avec les pilotes Canon. Je ne vais donc pas prendre le risque de tout casser pour réparer un logiciel qui peut être remplacé par un autre. S'il est impossible de réparer simple-scan sans procéder à une réinstallation complète du système, je vais laisser tomber. Quitte à tout réinstaller, autant attendre la mise à jour LM 19.1 prévue pour la fin de l'année, je crois.

Toutefois, si l'un d'entre vous pouvait me mettre le résultat des commandes apt-cache sur un LM 19 où simple-scan fonctionne, peut-être que cela me permettrait de voir s'il me manque quelque chose. C'est ce que je soupçonne depuis le début pour avoir fait naïvement confiance au Gestionnaire de Paquets en supprimant tous les paquets marqués comme pouvant être supprimés, sans vérifier à quoi ils servaient.

A+
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19 Tara - Cinnamon 3.8.9
Noyau Linux 4.15.0-36-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

Avatar du membre
tyrry
Messages : 3885
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Comment réparer simple-scan ?

Messagepar tyrry » lun. 15 oct. 2018 17:29

Slt ,
il n'y a rien de radical et ce que je te propose ne risque rien pour ton système ;)
après si tu veux pas ou à peur , ben tant pis ;) fait au moins les 2 premières commandes ;)
@+
Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: SolydX 9 (stretch)
Kernel: 4.9.0-6-amd64 x86_64
CPU: Intel Core i3-2130 RAM: -8 go Graphics Card: Intel 2nd Generation Core Processor
Dicton de tyrry : C'est pas parce qu'on sait pas se servir de xfce qu'il est nul........


Retourner vers « Logiciels »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité