[résolu] Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Pour un problème lié uniquement à Cinnamon
henry
Messages : 7
Enregistré le : mer. 28 sept. 2016 11:45

[résolu] Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar henry » jeu. 14 juin 2018 11:00

Bonjour,
Jusqu'ici tout allait bien, et tout d'un coup, je relance mon ordinateur et a l'affichage de la fenetre de connexion, je n'ai plus le choix d'utilisateurs, mais seulement de l'invité !!! La fenêtre ne s'affiche plus comme avant, plus de possibilité de choisir cinnamon ou autre...
Merci pour votre aide
Carte mère : Gigabyte 970 A-DS3P
Linux Cinnamon 18.3
Modifié en dernier par arghlub le jeu. 14 juin 2018 19:55, modifié 1 fois.
Raison : mise en [résolu]

mpedro
Messages : 1526
Enregistré le : dim. 8 nov. 2015 22:13
Contact :

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar mpedro » jeu. 14 juin 2018 11:32

peut etre quelque chose comme ça si le gestionnaire de session est lightdm sous LM18 [lightdm sudo dpkg-reconfigure lightdm] pour reprendre en compte le choix des utilisateurs car il n'y a pas besoin de l'utilitaire graphique users-admin des utilisateurs pour que le gestionnaire de session face apparaître les utilisateurs
attends d'autres réponses avant de faire car je poste comme ça vient

vérifies "utilisateurs et groupes" à partir du Menu/Administration pour vérifier si tout est ok de ce coté là
Stretch 32bits cinnamon/Fedora25/Sarah
Compaq 8510p/MSI GE70/Raspberry Pi2

Avatar du membre
arghlub
modérateur
Messages : 4139
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar arghlub » jeu. 14 juin 2018 13:23

Salut,

D'abord, vérifie que ton gestionnaire de session est bien LightDM car si tu as fais des upgrades de LinuxMint18.1→18.2→18.3, c'est peut-être encore MDM (LightDM n'est apparu qu'à la version 18.2).
Pour cela, regarde le résultat de cette commande :

Code : Tout sélectionner

cat /etc/X11/default-display-manager

Si c'est LightDM, dans le répertoire «/usr/share/lightdm/lightdm.conf.d/», tu as les fichiers de configuration.

Donc ouvre ces fichiers et vérifie que tu n'as pas une ligne avec cette variable à l'intérieur de l'un d'entre eux :

Code : Tout sélectionner

greeter-hide-users=true
Si c'est le cas, passe la à «false» (en éditant le fichier en «sudo»).
;)
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | MX Linux 17.1 | LinuxMint 19 Tara | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | tripleBoot : Debian 9 | MX Linux 17.1 | LinuxMint 19 | XFCE (bien sûr ...)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

henry
Messages : 7
Enregistré le : mer. 28 sept. 2016 11:45

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar henry » jeu. 14 juin 2018 14:17

Bonjour
Merci pour ton aide
Voici les réponses aux questions :

Code : Tout sélectionner

henry@coco ~ $ cat /etc/X11/default-display-manager
/usr/sbin/lightdm
henry@coco ~ $ cd /usr/share/lightdm/lightdm.conf.d/
henry@coco /usr/share/lightdm/lightdm.conf.d $ ls
50-disable-log-backup.conf  50-guest-wrapper.conf    90-slick-greeter.conf
50-greeter-wrapper.conf     50-xserver-command.conf

Aucun de ces fichiers ne contient greeter-hide-users=true
En fait la fenêtre de connexion semble à peu près normale, mais ne propose qu'une connexion invité
Merci pour tes conseils
Cordialement
Henry
Modifié en dernier par arghlub le jeu. 14 juin 2018 14:26, modifié 1 fois.
Raison : ajout de balises [code] aux commandes Terminal

henry
Messages : 7
Enregistré le : mer. 28 sept. 2016 11:45

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar henry » jeu. 14 juin 2018 14:20

Bonjour
Pour répondre à mPedro :
La commande : lightdm sudo dpkg-reconfigure lightdm
ou : sudo dpkg-reconfigure lightdm
ne fait pas disparaitre le problème
Merci pour ton aide
Cordialement
Henry

Avatar du membre
arghlub
modérateur
Messages : 4139
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar arghlub » jeu. 14 juin 2018 14:34

Regarde aussi dans le fichier de config du répertoire : «/etc/lightdm/»
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | MX Linux 17.1 | LinuxMint 19 Tara | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | tripleBoot : Debian 9 | MX Linux 17.1 | LinuxMint 19 | XFCE (bien sûr ...)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

henry
Messages : 7
Enregistré le : mer. 28 sept. 2016 11:45

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar henry » jeu. 14 juin 2018 16:08

Voici la manip:

Code : Tout sélectionner

coco ~ # cd /etc/lightdm/
coco lightdm # ls
lightdm.conf    lightdm-gtk-greeter.conf.d  users.conf
lightdm.conf.d  slick-greeter.conf

j'ai édité le fichier lightdm.conf : J'ai mis à false l'option demandée et au merveille j'ai de nouveau l'invite avec la proposition de conexion des utilisateurs
merci beaucoup pour ton aide efficace
Cordialement
Henry
Modifié en dernier par arghlub le jeu. 14 juin 2018 19:50, modifié 1 fois.
Raison : ajout de balises [code] aux commandes Terminal

henry
Messages : 7
Enregistré le : mer. 28 sept. 2016 11:45

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar henry » jeu. 14 juin 2018 16:09

il s'agit bien de : greeter-hide-users=true que j'ai mis à false

Avatar du membre
david37
modérateur
Messages : 2572
Enregistré le : lun. 22 août 2016 05:06

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar david37 » jeu. 14 juin 2018 18:14

Salut Henry,

Cool que tu es résolu ton problème, par contre pour mettre un sujet en résolu, c'est le premier message qu'il faut éditer ;)

si le sujet est résolu merci d'éditer le premier message du sujet, puis :
  1. mettre un petit Image, comme suit: voir tuto ici
  2. mettre un [résolu] (entre crochets et à gauche) dans le titre de ce premier message
PC1: Hp pavilion g6 / 1.36 GHz AMD E2-1800 APU with Radeon(tm) HD Graphics / 500 GB hard drive / 4G RAM /
LM 18.3 Mate x64
PC2: Hp-Pavilion Slimline / 2.5 GHz AMD RV710 / 4GB RAM / 500 GB hard drive / LM 18.3 Mate x64 & LM 18.3 Cinnamon x64
PC3: Lenovo ThinkPad R61i / 1.87 GHz Intel T2390 / NVIDIA G86M / 2GB RAM / 100 GB Hard Drive / LMDE2-Mate x64
PC4: Dell-Latitude E7240 / 2GHz i5-4310U / Intel Haswell-ULT HD 4400 / 8GB RAM / 256 GB Hard Drive / LM19 xfce x64

Avatar du membre
arghlub
modérateur
Messages : 4139
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Plus d'affichage des utilisateurs à la fenêtre de connexion en mode Graphique

Messagepar arghlub » jeu. 14 juin 2018 19:54

Super si tout est rentré dans l'ordre 8-)

Pour la mise en [résolu], cadeau : je le fais à ta place.

Et j'ai aussi repris certains de tes messages pour mettre les commandes du terminal entre balises "Code".
Il faut utiliser ces balises pour tout ce qui concerne le terminal (commandes, retours de commandes, etc…), cela améliore grandement la lisibilité.
Voir tuto Barre d'outils des messages Image
Merci d'y penser pour les prochaines fois.
;)
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | MX Linux 17.1 | LinuxMint 19 Tara | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | tripleBoot : Debian 9 | MX Linux 17.1 | LinuxMint 19 | XFCE (bien sûr ...)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April


Retourner vers « CINNAMON »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité