fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Installation, configuration des logiciels que vous souhaitez installer.
JeanJeanLaFlibuste
Messages : 12
Enregistré le : mer. 13 sept. 2017 15:46

fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar JeanJeanLaFlibuste » jeu. 14 sept. 2017 08:55

Bonjour à tous,
Petite question : ayant la volonté de contrôler mon ventilateur bruyant se mettant en route de manière anarchique sinon aléatoire (parfois à 35 degrés, parfois à 60) j'ai installé lm-sensors afin d'obtenir le plein contrôle sur mon ventilo. Or, quand je tape dans mon terminal un sudo pwmconfig, voilà ce que ça me renvoie:

Code : Tout sélectionner

sudo pwmconfig
[sudo] Mot de passe de jules :
# pwmconfig revision 6243 (2014-03-20)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed


Comment obtenir le plein contrôle sur mon ventilo? Qu'est-ce qu'un pwm-capable sensor?
Notebook Clevo W51XTU / Laptop / Linux Mint 18.1 Serena / Xfce 4.12.3 / 4.4.0-93-generic x86_64 (64 bit) / Dual core Intel Celeron N2830 (-MCP-) /
1Go de RAM et HDD de 60 Go (non-partitionné) / Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display

Avatar du membre
Geck
Messages : 77
Enregistré le : mar. 11 août 2015 16:33

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar Geck » jeu. 14 sept. 2017 11:52

JeanJeanLaFlibuste a écrit :Comment obtenir le plein contrôle sur mon ventilo? Qu'est-ce qu'un pwm-capable sensor?


Un "pwm-capable sensor" c'est un capteur autorisant la modulation de la vitesse du ventilateur.
En français c'est la MLI.
https://fr.wikipedia.org/wiki/Modulation_de_largeur_d%27impulsion

Je dirais que c'est la capacité de ton PC à faire varier la vitesse de son ventilateur.

Que te donne la commande :

Code : Tout sélectionner

sensors


Sur le PC que j'utilise là, cette commande m'indique juste les températures des quatre coeurs de mon processeur. Pas la vitesse du ventilateur. J'en déduis que sur mon PC non plus il n'y a pas le fameux capteur.

De mémoire il faut que le ventilateur soit branché avec un câble à trois fils, le jaune pour le capteur. Mais sur un PC portable je doute qu'on puisse voir les fameux fils. :l

J'ai croisé sur le Web une info qui date de 2012 qui parle d'un manque du noyau linux pour gérer le fameux capteur dans une certaine config... pas sûr que tu sois dans ce cas... D'un autre côté ton portable n'a pas l'air tout jeune... est-ce que tu sais si son BIOS est à jour ?
Image

JeanJeanLaFlibuste
Messages : 12
Enregistré le : mer. 13 sept. 2017 15:46

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar JeanJeanLaFlibuste » ven. 15 sept. 2017 01:40

Dacodac, je vois mieux maintenant. Désolé de la latence de la réponse mais comme vous allez le lire, drôle de problème.
la commande sensors me renvoie:

Code : Tout sélectionner

sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:         +0.0°C  (crit = +120.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +45.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +45.0°C  (high = +105.0°C, crit = +105.0°C)


Mon laptop a maintenant quatre ans mais il fonctionne très bien (je ne l'utilise que pour taper du texte) outre ce "problème" de ventilo déjà présent lors des premiers jours.
En ouvrant le capot, je ne vois pas du tout la connectique du ventilo. Too bad.
J'ai vérifié la version du bios. J'ai en effet quelque trains de retard.
J'ai donc essayé de charger une clef freeDOS pour installer l'.exe. Sauf que voilà: impossible de booter sur la clef. Soit, j'en essaie une autre. Toujours pas. Je change d'ordi de création de clef. Toujours pas. Je change à nouveau de clef. Toujours pas. J'ai fais la même manip avec une clef de boot Win7. Rien n'y fait.
Lorsque je suis dans le bios et que je tente de faire un boot override, j'ai une saut de l'écran en noir et je me retrouve au même endroit du bios...
Drôle de galère. Qu'en pensez-vous?
Notebook Clevo W51XTU / Laptop / Linux Mint 18.1 Serena / Xfce 4.12.3 / 4.4.0-93-generic x86_64 (64 bit) / Dual core Intel Celeron N2830 (-MCP-) /
1Go de RAM et HDD de 60 Go (non-partitionné) / Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display

Avatar du membre
alain
Messages : 2947
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar alain » ven. 15 sept. 2017 06:35

Bonjour JeanJeanLaFlibuste.

Pour ton problème de mise à jour du bios, je n'en pense strictement rien.. Désolé :oops:
Je peux juste te dire que j'ai des cartes mères avec des bios infiniment plus anciens que les tiens, et que sur certaines (bien entendu il faut quelles soient équipées d'origine de prise 4 pins)
j'ai le contrôle des fans.
Mais pour en revenir à ton problème, je pense que oui, mais je tiens à m'en assuré. As tu fait sensors-detect après avoir installé lm-sensors ?

Code : Tout sélectionner

sudo sensors-detect

répondre "yes" à toutes les questions.
Puis:

Code : Tout sélectionner

sensors

Pour voir si ça a changé quelque chose.
Image

Avatar du membre
zebulon
Administrateur du site
Messages : 9758
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar zebulon » ven. 15 sept. 2017 08:05

Salut ;)
Dans ton bios, tu n'as pas de réglage pour le ventilo (optimisé, silencieux, rapide) ?
LMDE MATE 64-bit, noyau: 4.9.0 +Lm 17.3 MATE.
Proc: intel I5 4440, Cm: Gigabyte GA-B85M-D3H, Alim: Corsair CX Bronze 430 W, Ram: Crucial Ballistix Sport, 2 x 2 Go.
SSD: 2.5 sandisk ultra+ 64 Go pour /+home, DD: Seagate Barracuda 500 Go pour mes données persos, DD maxtor 160 Go pour la sauvegarde ciblée via luckybackup.
Impr: HP Envy 4502.

JeanJeanLaFlibuste
Messages : 12
Enregistré le : mer. 13 sept. 2017 15:46

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar JeanJeanLaFlibuste » sam. 16 sept. 2017 12:16

Bonjour à tous,
Pour le BIOS, j'ai rééssayé, chose très étrange, j'arrive à booter sur des clefs Ubuntu et Lubuntu.
Je l'ai déjà exploré de fond en comble, chose que j'ai refaite, je n'ai rien trouvé de cnnexe au contrôle des ventilo. C'est un BIOS assez sommaire American Megatrends.
J'ai refait un sensors-detect, que j'avais déjà fait, répondu yes à toutes les questions, rien n'y fait, le sensors me renvoie toujours un:

Code : Tout sélectionner

sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:         +0.0°C  (crit = +120.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +35.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +35.0°C  (high = +105.0°C, crit = +105.0°C)


Voilà voilà... Des idées?
Merci de vos réponses
Notebook Clevo W51XTU / Laptop / Linux Mint 18.1 Serena / Xfce 4.12.3 / 4.4.0-93-generic x86_64 (64 bit) / Dual core Intel Celeron N2830 (-MCP-) /
1Go de RAM et HDD de 60 Go (non-partitionné) / Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display

Avatar du membre
tyrry
Messages : 2757
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar tyrry » dim. 17 sept. 2017 15:17

Slt ,
as tu essayer d'installer lm-sensors ?
normalement celui ci devrait venir en complément de fancontrol & pwmconfig ;)

Code : Tout sélectionner

sudo apt install lm-sensors

vérifie aussi la présence de libsensors4 ;)
redémarre et test ;)
@+
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya
CPU~Dual core Pentium E5400 RAM -8 go Kernel: 4.13.0-16-generic x86_64

JeanJeanLaFlibuste
Messages : 12
Enregistré le : mer. 13 sept. 2017 15:46

Re: fancontrol & pwmconfig : There are no pwm-capable sensor modules installed

Messagepar JeanJeanLaFlibuste » dim. 17 sept. 2017 17:39

Bonjour,
Je commence à vraiment me demander ce qu'il se passe là....

Code : Tout sélectionner

sudo apt install lm-sensors
[sudo] Mot de passe de jules :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
lm-sensors is already the newest version (1:3.4.0-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 10 non mis à jour.
jules@jules-W51XTU ~ $ dpkg -l | grep libsensors4
ii  libsensors4:amd64                           1:3.4.0-2                                    amd64        library to read temperature/voltage/fan sensors
ii  libsensors4:i386                            1:3.4.0-2                                    i386         library to read temperature/voltage/fan sensors


lm-sensors est bien installé et lisensors4 est installé et correctement configuré... :/
Notebook Clevo W51XTU / Laptop / Linux Mint 18.1 Serena / Xfce 4.12.3 / 4.4.0-93-generic x86_64 (64 bit) / Dual core Intel Celeron N2830 (-MCP-) /
1Go de RAM et HDD de 60 Go (non-partitionné) / Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display


Retourner vers « Logiciels »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités