[Fini] Erreur pour lancer la dernière image

Assistance concernant Linux Mint
Onesime
Messages : 12
Enregistré le : jeu. 23 nov. 2017 21:27

[Fini] Erreur pour lancer la dernière image

Messagepar Onesime » jeu. 23 nov. 2017 21:45

Bonsoir,
Depuis quelques semaines, je n'arrive pas à faire les mises à jour via le gestionnaire de mises à jour, notamment la maj "Noyau Linux 4.10.0-40...".
J'obtiens ce message d'erreur: "E: linux-image-extra-4.10.0-40-generic: le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1"
et voici les informations détaillées:

Code : Tout sélectionner

Préconfiguration des paquets...
(Lecture de la base de données... 810108 fichiers et répertoires déjà installés.)
Suppression de linux-image-extra-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.10.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-40-generic
Warning: No support for locale: fr_FR.utf8
depmod: WARNING: could not open /var/tmp/mkinitramfs_bdcj0S/lib/modules/4.10.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_bdcj0S/lib/modules/4.10.0-40-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-40-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-40-generic (--remove) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
Paramétrage de linux-image-extra-4.10.0-37-generic (4.10.0-37.41~16.04.1) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-37-generic /boot/vmlinuz-4.10.0-37-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-37-generic /boot/vmlinuz-4.10.0-37-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-37-generic /boot/vmlinuz-4.10.0-37-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-37-generic
Warning: No support for locale: fr_FR.utf8

gzip: stdout: No space left on device
cpio: erreur d'écriture: Relais brisé (pipe)
find: «standard output»: Relais brisé (pipe)
find: erreur d'écriture
E: mkinitramfs failure find 1 cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-37-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-37-generic (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de initramfs-tools (0.122ubuntu8.9) ...
update-initramfs: deferring update (trigger activated)
Paramétrage de linux-firmware (1.157.13) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-37-generic
Warning: No support for locale: fr_FR.utf8

gzip: stdout: No space left on device
cpio: erreur d'écriture: Relais brisé (pipe)
find: «standard output»: Relais brisé (pipe)
find: erreur d'écriture
E: mkinitramfs failure find 1 cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-37-generic with 1.
dpkg: erreur de traitement du paquet linux-firmware (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de linux-image-4.10.0-38-generic (4.10.0-38.42~16.04.1) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
The link /initrd.img is a dangling linkto /boot/initrd.img-4.10.0-38-generic
vmlinuz(/boot/vmlinuz-4.10.0-38-generic
) points to /boot/vmlinuz-4.10.0-38-generic
 (/boot/vmlinuz-4.10.0-38-generic) -- doing nothing at /var/lib/dpkg/info/linux-image-4.10.0-38-generic.postinst line 491.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-38-generic /boot/vmlinuz-4.10.0-38-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-38-generic
Warning: No support for locale: fr_FR.utf8

gzip: stdout: No space left on device
cpio: erreur d'écriture: Relais brisé (pipe)
find: «standard output»: Relais brisé (pipe)
find: erreur d'écriture
E: mkinitramfs failure find 1 cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-38-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-4.10.0-38-generic.postinst line 1052.
dpkg: erreur de traitement du paquet linux-image-4.10.0-38-generic (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 2
dpkg: des problèmes de dépendances empêchent la configuration de linux-image-extra-4.10.0-38-generic :
 linux-image-extra-4.10.0-38-generic dépend de linux-image-4.10.0-38-generic ; cependant :
 Le paquet linux-image-4.10.0-38-generic n'est pas encore configuré.

dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-38-generic (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour initramfs-tools (0.122ubuntu8.9) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-37-generic
Warning: No support for locale: fr_FR.utf8

gzip: stdout: No space left on device
cpio: erreur d'écriture: Relais brisé (pipe)
find: «standard output»: Relais brisé (pipe)
find: erreur d'écriture
E: mkinitramfs failure find 1 cpio 1 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-37-generic with 1.
dpkg: erreur de traitement du paquet initramfs-tools (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-37-generic
 linux-firmware
 linux-image-4.10.0-38-generic
 linux-image-extra-4.10.0-38-generic
 initramfs-tools



Au démarrage, LinuxMint m'affiche un écran noir et rien ne se lance. Il faut qu'au moment du démarrage je choisisse l'avant dernière version pour pouvoir lancer linux.

Si j'essaie de passer par le terminal, voici le code que j'obtiens:

Code : Tout sélectionner

sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  linux-image-extra-4.10.0-40-generic
Les paquets suivants seront mis à jour :
  boot-repair boot-sav dnsmasq-base klibc-utils libdb5.3 libdb5.3:i386
  libklibc libraw15 libsmbclient libwbclient0 python-samba samba-common
  samba-common-bin samba-libs smbclient
15 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
6 partiellement installés ou enlevés.
Il est nécessaire de prendre 295 ko/9 732 ko dans les archives.
Après cette opération, 156 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 ftp://ftp.rezopole.net/ubuntu xenial-updates/main amd64 dnsmasq-base amd64 2.75-1ubuntu0.16.04.4 [295 kB]
295 ko réceptionnés en 1s (247 ko/s) 
Préconfiguration des paquets...
(Lecture de la base de données... 810108 fichiers et répertoires déjà installés.)
Suppression de linux-image-extra-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.10.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-40-generic
Warning: No support for locale: fr_FR.utf8
depmod: WARNING: could not open /var/tmp/mkinitramfs_crlGOU/lib/modules/4.10.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_crlGOU/lib/modules/4.10.0-40-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-40-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-40-generic (--remove) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Quelqu'un pourrait-il m'aider à réparer le problème?
Merci
Modifié en dernier par Onesime le ven. 8 déc. 2017 20:41, modifié 2 fois.
Ordi: Lenovo Thinkpad X220 - IntelCore i5-2520M CPU@2,50GHz*2 - Ram: 16Go - HDD=500 Go
OS: DualBoot: Windows 10 64 bits & LinuxMint 18.2 Cinnamon 64bits.

Avatar du membre
tyrry
Messages : 2880
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Erreur sur dernière version

Messagepar tyrry » jeu. 23 nov. 2017 22:03

Slt ,
en premier :

Code : Tout sélectionner

sudo apt update

Code : Tout sélectionner

sudo apt install -f


Code : Tout sélectionner

sudo apt autoremove && sudo apt clean

Code : Tout sélectionner

sudo apt dist-upgrade


et dis nous le retour ;)
@+
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya Kernel: 4.13.0-16-generic x86_64
CPU: Dual core Pentium E5400 RAM: -8 go Graphics Card: Intel 4 Series

Onesime
Messages : 12
Enregistré le : jeu. 23 nov. 2017 21:27

Re: Erreur sur dernière version

Messagepar Onesime » jeu. 23 nov. 2017 22:09

Toujours les mêmes soucis:

Code : Tout sélectionner

onesime-X220-mint onesime # sudo apt update
Ign:1 http://mint-mirror.gwendallebihan.net/packages sonya InRelease
Atteint:2 http://security.ubuntu.com/ubuntu xenial-security InRelease                                                       
Atteint:3 http://archive.canonical.com/ubuntu xenial InRelease                                                               
Atteint:4 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease                                                     
Atteint:5 http://mint-mirror.gwendallebihan.net/packages sonya Release                                                             
Atteint:6 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu xenial InRelease                                                 
Atteint:7 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial InRelease   
Atteint:8 ftp://ftp.rezopole.net/ubuntu xenial InRelease                           
Atteint:10 ftp://ftp.rezopole.net/ubuntu xenial-updates InRelease
Atteint:11 ftp://ftp.rezopole.net/ubuntu xenial-backports InRelease
Lecture des listes de paquets... Fait 
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
15 packages can be upgraded. Run 'apt list --upgradable' to see them.

Code : Tout sélectionner

onesime-X220-mint onesime # sudo apt install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  linux-image-extra-4.10.0-40-generic
0 mis à jour, 0 nouvellement installés, 1 à enlever et 15 non mis à jour.
6 partiellement installés ou enlevés.
Après cette opération, 156 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 810108 fichiers et répertoires déjà installés.)
Suppression de linux-image-extra-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.10.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-40-generic
Warning: No support for locale: fr_FR.utf8
depmod: WARNING: could not open /var/tmp/mkinitramfs_qcBw9c/lib/modules/4.10.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_qcBw9c/lib/modules/4.10.0-40-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-40-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-40-generic (--remove) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code : Tout sélectionner

onesime-X220-mint onesime # sudo apt autoremove && sudo apt clean
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  linux-image-extra-4.10.0-40-generic
0 mis à jour, 0 nouvellement installés, 1 à enlever et 15 non mis à jour.
6 partiellement installés ou enlevés.
Après cette opération, 156 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 810108 fichiers et répertoires déjà installés.)
Suppression de linux-image-extra-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.10.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-40-generic
Warning: No support for locale: fr_FR.utf8
depmod: WARNING: could not open /var/tmp/mkinitramfs_dXcPSw/lib/modules/4.10.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_dXcPSw/lib/modules/4.10.0-40-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-40-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-40-generic (--remove) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code : Tout sélectionner

onesime-X220-mint onesime # sudo apt dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  linux-image-4.10.0-40-generic
Les paquets suivants seront mis à jour :
  boot-repair boot-sav dnsmasq-base klibc-utils libdb5.3 libdb5.3:i386 libklibc libraw15 libsmbclient libwbclient0 python-samba samba-common samba-common-bin samba-libs smbclient
15 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
6 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/59,7 Mo dans les archives.
Après cette opération, 70,1 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Préconfiguration des paquets...
(Lecture de la base de données... 810109 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../klibc-utils_2.0.4-8ubuntu1.16.04.4_amd64.deb ...
Dépaquetage de klibc-utils (2.0.4-8ubuntu1.16.04.4) sur (2.0.4-8ubuntu1.16.04.3) ...
Préparation du dépaquetage de .../libklibc_2.0.4-8ubuntu1.16.04.4_amd64.deb ...
Dépaquetage de libklibc (2.0.4-8ubuntu1.16.04.4) sur (2.0.4-8ubuntu1.16.04.3) ...
Préparation du dépaquetage de .../linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
Done.
Dépaquetage de linux-image-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb (--unpack) :
 impossible de copier les données extraites pour « ./boot/vmlinuz-4.10.0-40-generic » vers « /boot/vmlinuz-4.10.0-40-generic.dpkg-new » : échec d'écriture (Aucun espace disponible sur le périphérique)
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
The link /initrd.img is a damaged link
Removing symbolic link initrd.img
 you may need to re-run your boot loader[grub]
The link /initrd.img.old is a damaged link
Removing symbolic link initrd.img.old
 you may need to re-run your boot loader[grub]
Préparation du dépaquetage de .../python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_amd64.deb ...
Dépaquetage de python-samba (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../samba-common-bin_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_amd64.deb ...
Dépaquetage de samba-common-bin (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../smbclient_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_amd64.deb ...
Dépaquetage de smbclient (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../samba-libs_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_amd64.deb ...
Dépaquetage de samba-libs:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../libwbclient0_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_amd64.deb ...
Dépaquetage de libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../libsmbclient_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_amd64.deb ...
Dépaquetage de libsmbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../samba-common_2%3a4.3.11+dfsg-0ubuntu0.16.04.12_all.deb ...
Dépaquetage de samba-common (2:4.3.11+dfsg-0ubuntu0.16.04.12) sur (2:4.3.11+dfsg-0ubuntu0.16.04.11) ...
Préparation du dépaquetage de .../libdb5.3_5.3.28-11ubuntu0.1_amd64.deb ...
Déconfiguration de libdb5.3:i386 (5.3.28-11) ...
Dépaquetage de libdb5.3:amd64 (5.3.28-11ubuntu0.1) sur (5.3.28-11) ...
Préparation du dépaquetage de .../libdb5.3_5.3.28-11ubuntu0.1_i386.deb ...
Dépaquetage de libdb5.3:i386 (5.3.28-11ubuntu0.1) sur (5.3.28-11) ...
Préparation du dépaquetage de .../boot-sav_4ppa65_all.deb ...
Dépaquetage de boot-sav (4ppa65) sur (4ppa64) ...
Préparation du dépaquetage de .../boot-repair_4ppa65_all.deb ...
Dépaquetage de boot-repair (4ppa65) sur (4ppa64) ...
Préparation du dépaquetage de .../dnsmasq-base_2.75-1ubuntu0.16.04.4_amd64.deb ...
Dépaquetage de dnsmasq-base (2.75-1ubuntu0.16.04.4) sur (2.75-1ubuntu0.16.04.3) ...
Préparation du dépaquetage de .../libraw15_0.17.1-1ubuntu0.1_amd64.deb ...
Dépaquetage de libraw15:amd64 (0.17.1-1ubuntu0.1) sur (0.17.1-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu9) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22+linuxmint1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour dbus (1.10.6-1ubuntu3.3) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ordi: Lenovo Thinkpad X220 - IntelCore i5-2520M CPU@2,50GHz*2 - Ram: 16Go - HDD=500 Go
OS: DualBoot: Windows 10 64 bits & LinuxMint 18.2 Cinnamon 64bits.

Avatar du membre
tyrry
Messages : 2880
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Erreur sur dernière version

Messagepar tyrry » jeu. 23 nov. 2017 22:30

Slt ,
puisque tu démarre sous un autre noyau que celui qui t'embête :

Code : Tout sélectionner

sudo apt remove linux-image-4.10.0-40-generic linux-image-extra-4.10.0-40-generic

Code : Tout sélectionner

sudo os-prober

Code : Tout sélectionner

sudo update-grub

redémarre et retente les maj ;)
@+
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya Kernel: 4.13.0-16-generic x86_64
CPU: Dual core Pentium E5400 RAM: -8 go Graphics Card: Intel 4 Series

Onesime
Messages : 12
Enregistré le : jeu. 23 nov. 2017 21:27

Re: Erreur sur dernière version

Messagepar Onesime » ven. 24 nov. 2017 08:19

Voici ce que ça donne, je retente le redémarrage

Code : Tout sélectionner

sudo apt remove linux-image-4.10.0-40-generic linux-image-extra-4.10.0-40-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet « linux-image-4.10.0-40-generic » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants seront ENLEVÉS :
  linux-image-extra-4.10.0-40-generic
0 mis à jour, 0 nouvellement installés, 1 à enlever et 2 non mis à jour.
21 partiellement installés ou enlevés.
Après cette opération, 156 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O     
(Lecture de la base de données... 810108 fichiers et répertoires déjà installés.)
Suppression de linux-image-extra-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.10.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-40-generic
Warning: No support for locale: fr_FR.utf8
depmod: WARNING: could not open /var/tmp/mkinitramfs_dD7fgH/lib/modules/4.10.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_dD7fgH/lib/modules/4.10.0-40-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-40-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-40-generic (--remove) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code : Tout sélectionner

onesime-X220-mint onesime # sudo os-prober
/dev/sda1:Windows 10 (loader):Windows:chain

Code : Tout sélectionner

onesime-X220-mint onesime # sudo update-grub
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.10.0-38-generic
Image Linux trouvée : /boot/vmlinuz-4.10.0-37-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-37-generic
Image Linux trouvée : /boot/vmlinuz-4.10.0-35-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-35-generic
Image Linux trouvée : /boot/vmlinuz-4.10.0-33-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-33-generic
Image Linux trouvée : /boot/vmlinuz-4.10.0-32-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.10.0-32-generic
Image Linux trouvée : /boot/vmlinuz-4.8.0-53-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.8.0-53-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-91-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-91-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-89-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-89-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-87-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-87-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-83-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-83-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-81-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-81-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-79-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-79-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-78-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-78-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-77-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-77-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-75-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-75-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-72-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-72-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-71-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-71-generic
Image Linux trouvée : /boot/vmlinuz-4.4.0-53-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-53-generic
Found memtest86+ image: /memtest86+.elf
Found memtest86+ image: /memtest86+.bin
Windows 10 (loader) trouvé sur /dev/sda1
fait
Ordi: Lenovo Thinkpad X220 - IntelCore i5-2520M CPU@2,50GHz*2 - Ram: 16Go - HDD=500 Go
OS: DualBoot: Windows 10 64 bits & LinuxMint 18.2 Cinnamon 64bits.

Onesime
Messages : 12
Enregistré le : jeu. 23 nov. 2017 21:27

Re: Erreur sur dernière version

Messagepar Onesime » ven. 24 nov. 2017 08:39

Aucun changement après redémarrage, j'ai les même message d'erreur et l'image proposée par défaut ne démarre pas, je suis obligé d'aller dans les options avancées chercher l'avant dernière image
Ordi: Lenovo Thinkpad X220 - IntelCore i5-2520M CPU@2,50GHz*2 - Ram: 16Go - HDD=500 Go
OS: DualBoot: Windows 10 64 bits & LinuxMint 18.2 Cinnamon 64bits.

Avatar du membre
zebulon
Administrateur du site
Messages : 10000
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: Erreur sur dernière version

Messagepar zebulon » ven. 24 nov. 2017 08:45

Salut ;)
Je ne vais pas t'aider à résoudre ton probleme, mais plutôt te donner plus de chance d'avoir des réponses en plus de celles de tyrry 8-)
Quand on prend ton sujet en route, on ne sais pas de quoi on parle "Erreur sur dernière version".

Pour la personne qui aurait une solution mais qui n'a pas envie de relire le tout, c'est râpé :?
LMDE MATE 64-bit, noyau: 4.9.0 +Lm 17.3 MATE.
Proc: intel I5 4440, Cm: Gigabyte GA-B85M-D3H, Alim: Corsair CX Bronze 430 W, Ram: Crucial Ballistix Sport, 2 x 2 Go.
SSD: 2.5 sandisk ultra+ 64 Go pour /+home, DD: Seagate Barracuda 500 Go pour mes données persos, DD maxtor 160 Go pour la sauvegarde ciblée via luckybackup.
Impr: HP Envy 4502.

Avatar du membre
tyrry
Messages : 2880
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Erreur sur dernière version

Messagepar tyrry » ven. 24 nov. 2017 17:35

Slt ,
de ce que je comprend , c'est que tu as installer linux-image-extra-4.10.0-40-generic sans installer linux-image-4.10.0-40-generic !!
du coup ,

Code : Tout sélectionner

sudo apt update

Code : Tout sélectionner

sudo apt clean

Code : Tout sélectionner

sudo apt install -f linux-image-4.10.0-40-generic

si tout vas bien jusque là , tu peux ensuite redémarrer et finir tes maj

Code : Tout sélectionner

sudo apt dist-upgrade

@+
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya Kernel: 4.13.0-16-generic x86_64
CPU: Dual core Pentium E5400 RAM: -8 go Graphics Card: Intel 4 Series

Onesime
Messages : 12
Enregistré le : jeu. 23 nov. 2017 21:27

Re: Erreur sur dernière version

Messagepar Onesime » ven. 24 nov. 2017 17:59

Il y a toujours des messages d'erreur! :-/

Code : Tout sélectionner

onesime-X220-mint onesime # sudo apt update
Ign:1 http://mint-mirror.gwendallebihan.net/packages sonya InRelease
Atteint:2 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease       
Atteint:3 http://mint-mirror.gwendallebihan.net/packages sonya Release         
Atteint:4 http://security.ubuntu.com/ubuntu xenial-security InRelease         
Atteint:5 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu xenial InRelease
Atteint:7 http://archive.canonical.com/ubuntu xenial InRelease                 
Atteint:8 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial InRelease
Atteint:9 ftp://ftp.rezopole.net/ubuntu xenial InRelease                 
Atteint:10 ftp://ftp.rezopole.net/ubuntu xenial-updates InRelease
Atteint:11 ftp://ftp.rezopole.net/ubuntu xenial-backports InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
onesime-X220-mint onesime # sudo apt clean
onesime-X220-mint onesime # sudo apt install -f linux-image-4.10.0-40-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Paquets suggérés :
  fdutils linux-tools
Les paquets suivants seront ENLEVÉS :
  linux-image-extra-4.10.0-40-generic
Les NOUVEAUX paquets suivants seront installés :
  linux-image-4.10.0-40-generic
0 mis à jour, 1 nouvellement installés, 1 à enlever et 2 non mis à jour.
6 partiellement installés ou enlevés.
Il est nécessaire de prendre 20,2 Mo dans les archives.
Après cette opération, 85,8 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 ftp://ftp.rezopole.net/ubuntu xenial-updates/main amd64 linux-image-4.10.0-40-generic amd64 4.10.0-40.44~16.04.1 [20,2 MB]
20,2 Mo réceptionnés en 12s (1 555 ko/s)                                       
(Lecture de la base de données... 810108 fichiers et répertoires déjà installés.)
Suppression de linux-image-extra-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.10.0-40-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
update-initramfs: Generating /boot/initrd.img-4.10.0-40-generic
Warning: No support for locale: fr_FR.utf8
depmod: WARNING: could not open /var/tmp/mkinitramfs_TRJaF1/lib/modules/4.10.0-40-generic/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_TRJaF1/lib/modules/4.10.0-40-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.10.0-40-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: erreur de traitement du paquet linux-image-extra-4.10.0-40-generic (--remove) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 linux-image-extra-4.10.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
onesime-X220-mint onesime # sudo apt dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  linux-image-4.10.0-40-generic
Les paquets suivants seront mis à jour :
  chromium-browser chromium-codecs-ffmpeg-extra
2 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
6 partiellement installés ou enlevés.
Il est nécessaire de prendre 91,1 Mo/111 Mo dans les archives.
Après cette opération, 70,1 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 chromium-browser amd64 62.0.3202.94-0ubuntu0.16.04.1317 [60,3 MB]
Réception de:2 ftp://ftp.rezopole.net/ubuntu xenial-updates/main amd64 linux-image-extra-4.10.0-40-generic amd64 4.10.0-40.44~16.04.1 [29,8 MB]
Réception de:3 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 chromium-codecs-ffmpeg-extra amd64 62.0.3202.94-0ubuntu0.16.04.1317 [1 000 kB]                                                                               
91,1 Mo réceptionnés en 5min 8s (295 ko/s)                                                                                                                                                                                                   
(Lecture de la base de données... 810109 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
Done.
Dépaquetage de linux-image-4.10.0-40-generic (4.10.0-40.44~16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb (--unpack) :
 impossible de copier les données extraites pour « ./boot/vmlinuz-4.10.0-40-generic » vers « /boot/vmlinuz-4.10.0-40-generic.dpkg-new » : échec d'écriture (Aucun espace disponible sur le périphérique)
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.10.0-40-generic /boot/vmlinuz-4.10.0-40-generic
The link /initrd.img is a damaged link
Removing symbolic link initrd.img
 you may need to re-run your boot loader[grub]
Préparation du dépaquetage de .../chromium-browser_62.0.3202.94-0ubuntu0.16.04.1317_amd64.deb ...
Dépaquetage de chromium-browser (62.0.3202.94-0ubuntu0.16.04.1317) sur (62.0.3202.89-0ubuntu0.16.04.1315) ...
Préparation du dépaquetage de .../chromium-codecs-ffmpeg-extra_62.0.3202.94-0ubuntu0.16.04.1317_amd64.deb ...
Dépaquetage de chromium-codecs-ffmpeg-extra (62.0.3202.94-0ubuntu0.16.04.1317) sur (62.0.3202.89-0ubuntu0.16.04.1315) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22+linuxmint1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ordi: Lenovo Thinkpad X220 - IntelCore i5-2520M CPU@2,50GHz*2 - Ram: 16Go - HDD=500 Go
OS: DualBoot: Windows 10 64 bits & LinuxMint 18.2 Cinnamon 64bits.

Avatar du membre
tyrry
Messages : 2880
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Erreur sur dernière version

Messagepar tyrry » ven. 24 nov. 2017 18:02

Slt ,
ben je vois pas ce qui cloche , tu as pas trafiquer quelque chose en root ???
Ou voir a changer de dépôts et refaire les manips ( bizarre ton truc : /var/cache/apt/archives/linux-image-4.10.0-40-generic_4.10.0-40.44~16.04.1_amd64.deb )
A part te dire d'essayer d'installer carrément un autre noyau , exemple le 4.13........ je n'ai pas d'autres idée :?
@+
Modifié en dernier par tyrry le ven. 24 nov. 2017 18:07, modifié 1 fois.
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya Kernel: 4.13.0-16-generic x86_64
CPU: Dual core Pentium E5400 RAM: -8 go Graphics Card: Intel 4 Series


Retourner vers « Générale »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité