Perte windows après installation mint

Assistance concernant Linux Mint
clem9885
Messages : 5
Enregistré le : lun. 11 sept. 2017 23:53

Perte windows après installation mint

Messagepar clem9885 » mar. 12 sept. 2017 00:16

Bonsoir,
Je viens d'installer Mint 18.2 KDE, en utilisant le partitionnement manuel. J'ai un PC neuf avec Windows 10, j'avais plusieurs partition ntfs, j'ai réduit celle avec le plus d'espace, j'ai créé une partition ext4 avec comme point de montage / pour linux, une autre ext4 avec comme point de montage /home pour mes documents et un swap. Cependant j'ai dû faire une erreur puisque lors du redémarrage windows lance une réparation automatique mais ne parvient pas à réparer les erreurs, je ne parviens pas non plus à réinitialiser windows, je peux accéder à grub pour booter sur mint. Les fichiers systèmes de windows semblent être installés sur une des partitions ntfs alors que mes données et tout le reste était sur celle que j'ai réduite (la plus grosse environ 950 GB). Comment puis-je retrouver windows tout en gardant mint ou alors réinitialiser windows puis réinstaller mint correctement ?
Merci de votre aide.
Cordialement

Clem

Avatar du membre
bluc
Messages : 1339
Enregistré le : mar. 14 juil. 2015 07:50

Re: Perte windows après installation mint

Messagepar bluc » mar. 12 sept. 2017 01:25

Tu copies et colles ceci dans le terminal et tu colleras la réponse du terminal dans ton prochain message

Code : Tout sélectionner

fdisk -l
الكِلاب تَنبَح و القافِلة تَسير

clem9885
Messages : 5
Enregistré le : lun. 11 sept. 2017 23:53

Re: Perte windows après installation mint

Messagepar clem9885 » mar. 12 sept. 2017 02:12

Voici mon partitionnement:

Code : Tout sélectionner

clem@clem-OMEN-by-HP-Laptop ~/Documents $ fdisk -l
fdisk: impossible d'ouvrir /dev/sda: Permission non accordée
clem@clem-OMEN-by-HP-Laptop ~/Documents $ sudo fdisk -l
[sudo] Mot de passe de clem :
Disque /dev/sda : 931,5 GiB, 1000204886016 octets, 1953525168 secteurs
Unités : sectors of 1 * 512 = 512 octets
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 944A03A8-D0E5-4B42-81D0-B1C7400B29A6

Périphérique      Start        Fin  Secteurs   Size Type
/dev/sda1          2048     534527    532480   260M EFI System
/dev/sda2        534528     567295     32768    16M Microsoft reserved
/dev/sda3        567296  684161045 683593750   326G Microsoft basic data
/dev/sda4    1925994496 1928001535   2007040   980M Windows recovery environment
/dev/sda5    1928001536 1953513471  25511936  12,2G Microsoft basic data
/dev/sda6     684163072 1270097919 585934848 279,4G Linux filesystem
/dev/sda7    1270097920 1285722111  15624192   7,5G Partition d'échange Linux

Partition table entries are not in disk order.

Avatar du membre
zebulon
Administrateur du site
Messages : 9291
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: Perte windows après installation mint

Messagepar zebulon » mar. 12 sept. 2017 09:28

Salut,
Actu et bug du forum, voila le titre de la rubrique dans laquelle tu as posté :l
Je ne vois pas le rapport avec ton probleme, voici un lien que tu devrais lire http://forum-francophone-linuxmint.fr/v ... ?f=2&t=550
Je déplace dans général.

Merci !!
LMDE MATE 64-bit, noyau: 4.9.0 +Lm 17.3 MATE.
Proc: intel I5 4440, Cm: Gigabyte GA-B85M-D3H, Alim: Corsair CX Bronze 430 W, Ram: Crucial Ballistix Sport, 2 x 2 Go.
SSD: 2.5 sandisk ultra+ 64 Go pour /+home, DD: Seagate Barracuda 500 Go pour mes données persos, DD maxtor 160 Go pour la sauvegarde ciblée via luckybackup.
Impr: HP Envy 4502.

Avatar du membre
alain
Messages : 2638
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Perte windows après installation mint

Messagepar alain » jeu. 14 sept. 2017 05:45

Bonjour Clem.

As tu bien installé le programe de démarrage linux sur sda1 (partition EFI system) , tu ne le dis pas dans ton message.
Si oui tu peux essayer ça:

Code : Tout sélectionner

sudo os-prober

puis:

Code : Tout sélectionner

sudo update-grub

Et redémarre.

Si ça ne fonctionne pas tu peux aussi essayer avec boot-repair en live usb. Iso dispo ici par exemple : boot-repair-disk
Image

clem9885
Messages : 5
Enregistré le : lun. 11 sept. 2017 23:53

Re: Perte windows après installation mint

Messagepar clem9885 » lun. 18 sept. 2017 12:56

Bonjour Alain,
Excusez moi je n'avais pas vu votre réponse.
Je n'ai pas fais attention au lieu d'installation de grub, comment puis je savoir où celui-ci est installé ? Si il n'est pas installé au bon endroit, existe-t-il un moyen de réinstaller grub au bon endroit sans devoir réinstaller linux ?

Avatar du membre
mpat
Messages : 6850
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: Perte windows après installation mint

Messagepar mpat » lun. 18 sept. 2017 13:11

bonjour, le plus simple, tu relances l'installation de Linux tu choisis autre, tu désignes la partition sda6 pour ton sys et home tu ne coches pas formater, et tu désignes sda7 comme swap, cette façon de faire ne touchera en rien as se que tu as déjà.

surtout ne coches pas formater

mais lors du chois du système de démarrage tu dois choisir ta partition uefi/boot, car actuellement tu n'as plus aucunes partition de démarrage dans ta capture de partitionnement tu aurais du avoir un astérisque devant la partition amorçable.

comme ceci
/dev/sda1 * 2048 534527 532480 260M EFI System

Image

Image

en regardant de plus prêt je suis pas sur que tu ais réussi ton installation tu as ceci
/dev/sda6 684163072 1270097919 585934848 279,4G Linux filesystem


tu devrais avoir ceci.
/dev/sda6 684163072 1270097919 585934848 279,4G 83 Linux



voici un exemple de partitionnement avec amorçage
Image
Modifié en dernier par mpat le lun. 18 sept. 2017 13:45, modifié 3 fois.
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram
dual gpu Intel/Nvidia pilotes 384.59, ssd evo-pro850 256go + hdd 750go
Lmint 18.2 - Cinnamon 64-bit, kernel 4.13.2-041302

clem9885
Messages : 5
Enregistré le : lun. 11 sept. 2017 23:53

Re: Perte windows après installation mint

Messagepar clem9885 » lun. 18 sept. 2017 13:28

Bonjour, merci de votre réponse, j'essaie ça ce soir et je vous tiens au courant.


Retourner vers « Générale »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité